Support Center

Browser Requirements

Last updated August 15, 2017
Onehub's Google Drive functionality supports the two most recent versions of the following browsers:
‚Äč
If you're working in Internet Explorer 8 or 9 and would like to use Onehub, you will need to use another supported browser. You may be unable to upgrade your browser on your own. In this case, please contact your administrator or your IT support for further assistance.

This article specifically covers support for the Google Drive integration feature. The Onehub service still supports Internet Explorer version 10 and above.

Still need help? Contact us directly at (877) 644-7774 or